login  Naam:   Wachtwoord: 
Registreer je!
 Forum

anchor probleem

Offline webmaker - 05/11/2009 16:58
Avatar van webmakerPHP interesse Ik heb een upload formulier, en na de post doe ik het volgende:
header("Location: /members#message");
Nu doe linkt hij mij in internet explorer naar /members zorder # erachter. Hoe komt dit en hoe is dit op te lossen.
Dit is ook iemand met hetzelfde probleem en ze praten hier over een bug in IE:
http://www.webmasterworld.com/forum88/12176.htm

6 antwoorden

Gesponsorde links
Offline Martijn - 05/11/2009 18:24
Avatar van Martijn Crew PHP ik zou het niet weten, maar je zou het met javascript kunnen oplossen? window.location = "/members#message"; werkt vast
Offline Richard - 05/11/2009 19:44
Avatar van Richard Crew algemeen Nooit met JavaScript kloten, dat heeft geen nut.

In elk geval, het is een bug, je kunt er niks aan doen. :-)
Offline webmaker - 05/11/2009 19:54
Avatar van webmaker PHP interesse Is er dan niets om te onzeilen, in IE 8.0 doe hij het ook niet. In Chrome daarentegen werkt het perfect. De reden waarom ik dit ook met header oplos en niet met javascript is omdat php een server side taal is. Daarom versta ik mij er ook niet aan waarom hij dit doet?
Offline Martijn - 05/11/2009 19:54
Avatar van Martijn Crew PHP maar dan moet ie nog wel een oplossing 
Offline webmaker - 10/11/2009 10:40
Avatar van webmaker PHP interesse Is nu eigenlijk niemand die hiervoor een oplossing heeft. Op sima is dit toch ook, als je een bericht gepost hebt ga je naar dit bericht terug via de anchor. En die header() werkt wel in internet explorer.
Offline Martijn - 11/11/2009 14:18
Avatar van Martijn Crew PHP dan zou je even moeten hopen dat iemand met script toegang dit leest.

Laat is wat code zien waar je het mee doet?
Gesponsorde links
Dit onderwerp is gesloten.
Actieve forumberichten
© 2002-2020 Sitemasters.be - Regels - Laadtijd: 0.243s